SOLVED Help installing SSD to new laptop

amlothi

Well-Known Member
Silver Supporter
SoSH Member
Jan 5, 2007
563
I'm stumped and could use some help.

I have a brand new LG Gram laptop (15Z980-U.AAS5U1). I'm trying to install a Crucial MX500 1TB SSD. Per Crucial's website and LG support it should be compatible. One of the reasons I bought this laptop is because it is upgradeable and has a free slot to add a second SSD. Review comments from others indicate upgrading or adding a drive to this laptop is straightforward.

When I first install the SSD in the laptop, it boots fine to Windows. I can use Windows disk manager to initialize and format the drive. I can see the drive, add files, etc. However, as soon as I reboot, it gets stuck at the LG logo and goes into a boot loop. I cannot access BIOS either. This happens any time the new drive is installed regardless whether it's by itself, with the original drive, or which slot it's in.

If I take the new drive out, all works fine and it boots as normal. I can get into BIOS, verify the boot order is correct, etc. However, if the new drive is inserted, it goes back to a boot loop.

I can connect the new drive via an external mount and USB. Works fine. In this was, I was able to successfully clone the system drive to the new drive. I thought this might allow me to at least use the new, larger drive by itself. No luck - boot loop again.

Crucial support took me through several troubleshooting steps. They told me the drive may be bad and sent me a replacement overnight (much appreciated). I experience all of the above with the replacement drive.

I have created a windows recovery USB, but I can't boot to the USB when the new SSD is installed. I have also verified that BIOS is the most recent version.

The other strange thing is Crucial had me disable Secure Boot in the BIOS and then put the new drive in. When I do that, I immediately get a small blue box asking me to unlock the SSD with a prompt to enter a password. Crucial was not able to tell me what to enter there. The BIOS then appears to re-enable secure boot on it's own after a restart.

I've spoken with LG support as well and they ended up writing it all down and sending my ticket to second tier support. I'm waiting for a call back.

Any ideas on what else to try?
 

Harry Hooper

Well-Known Member
Lifetime Member
SoSH Member
Jan 4, 2002
26,186
Maybe you have some kind of BIOS-UEFI secure boot conflict going on. LINK


BTW, was the original hard drive also a SSD?
 
Last edited:

Omar's Wacky Neighbor

Well-Known Member
Lifetime Member
SoSH Member
Maybe you have some kind of BIOS-UEFI secure boot conflict going on. LINK
Sounds oddly familiar. A bunch of folks bought an HP laptop last Dec at costco, and that problem may have popped up with a few people.

On my way out, so sorry to not be more specific. Take a look thru this thread, search UEFI or similar:

 

amlothi

Well-Known Member
Silver Supporter
SoSH Member
Jan 5, 2007
563
Solved. In case anyone finds this thread, I had to piece together the solution from several sources.

Crucial® MX500 SSD advanced features
"Hardware-based encryption: Keep personal files and confidential data restricted from hackers and thieves with AES 256-bit encryption that meets all industry standards, including Microsoft® eDrive, IEEE1667, and TCG Opal 2.0."

"eDrive is a security storage specification defined by Microsoft for use with BitLocker. It is based on the TCG OPAL and IEEE 1667 specifications."


The disk drive lock (OPAL) is a security feature implemented on the disk drive itself. It is defined in Hard Disk ATA Standard. Both the user and the master drive lock password are stored directly on the disk drive on its controller board in a registry. The passwords are not stored on the disk's data areas that is plates in HDD or memory chips in SSD.
BIOS serves only to store the lock/unlock utility and communicate with the disk drive.
The above said means that the disk lock goes with the disk drive.


The message "Unlock CT500MX500SSD4" on your picture is asking for the user and/or the master disk drive lock password, which are both different from PSID code.
You need PSID code to unlock the drive with special utility - PSID reverting tool. In this case Crucial Storage Executive.

1) Take picture of PSID on drive. Attached by USB. Boot to windows on main drive.

2) You need to unmount the drive first.
The instructions said to do this:
1. Open an administrator command prompt.
2. Run the following command: compmgmt.msc
3. Select Disk Management.
4. Right-click on the target drive and select Offline.


I didn't have this option so I just deleted the partitions that were mounted.

3) Perform PSID Revert using Crucial Storage Executive tool

4) Prevent Windows from enabling encryption by either
1. set a HDD password in BIOS (because eDrive cannot become enabled while ATA security is enabled, and vice-versa).
2. set a registry entry prior to letting Windows Setup partition the drive:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EnhancedStorageDevices]
"TCGSecurityActivationDisabled"=dword:00000001


5) Then I could initialize the drive, create the partitions and all works fine.